Přidat otázku mezi oblíbenéZasílat nové odpovědi e-mailemVyřešeno Problém s vzorci excel

Zdravím, ahoj :)
potřeboval bych poradit od někoho kdo má zkušenosti se složitějšími vzorci v excelu.

řeším v excelu problém kdy mám tři slupce a veprostřed checkbox, viz příloha
když zaškrtnu checkbox chci aby se přičetla hodnota vlevo a když je odškrtnutý tak hodnota vpravo a to i třeba na přeskáčku viz obrázek se součtem (jen tak mimochodem na tom příkladu je to řešený prostým součtem, jen pro jistotu kvůli rejpalům)
jinak checkbox je propojený s buňkou ale nikde jsem jinou možnost rozlišování Pravda/Nepravda ve spojení s checkboxem nenašel

tzn. je to vůbec možné?
už jsem hledal všude možně ale nedaří se mi to poskládat

Všem předem děkuji za pomoc

Řešení:

Například něco takového v buňce B7?
=SUMIF(B1:B6;0;C1:C6)+SUMIF(B1:B6;1;A1:A6)

Předmět Autor Datum
Ja ti to uľahčím. Checkbox do tabuliek nepatrí, nahradil by som ho hodnotou 1/0, prípadne výberovým…
čitateľ 01.08.2020 15:25
čitateľ
Ten checkbox nahrazuje právě tu 1/0 když je přiřazený k buňce mění hodnotu buňky na pravda/nepravda,…
StStanley 01.08.2020 15:43
StStanley
Například něco takového v buňce B7? =SUMIF(B1:B6;0;C1:C6)+SUMIF(B1:B6;1;A1:A6)
Prim 01.08.2020 17:10
Prim
Díky toto funguje jen pozměnit 0/1 za PRAVDA/NEPRAVDA :) já věděl že to nějak jde jen jsem to celou…
StStanley 01.08.2020 19:03
StStanley
Checkboxy do tabulek patří. https://www.extendoffice.com/documents/excel/2460-excel-sum-count-checkb…
excel-checkbox 01.08.2020 17:14
excel-checkbox
=SOUČIN.SKALÁRNÍ((A1:A4)*(--B1:B4=1)+(C1:C4)*(--B1:B4=0))
Siki83 01.08.2020 17:44
Siki83
Prípadne ešte maticovým (CSE) vzorcom: =SUM((A1:A4)*((B1:B4)=TRUE);(C1:C4)*((B1:B4)=FALSE)) t.j. z… poslední
robert13 02.08.2020 09:12
robert13

Ten checkbox nahrazuje právě tu 1/0 když je přiřazený k buňce mění hodnotu buňky na pravda/nepravda, což ve výsledků mění jen to jestli budu klikat na buňku nebo přepisovat hodnotu, bohužel to ale neřeší problém pravá/levá od dané buňky a přičíst...

Jinak teď to mám řešeno přes SUMIFS s tím že jsem musel přidělat ještě jeden sloupec s checkboxy, kdy se pod každý sloupec sečtou dané hodnoty a až pak následně vytvořit součet v třetí buňce což je poněkud otravné, protože musí být možnost jak fci KDYŽ a součet použít současně....

Prípadne ešte maticovým (CSE) vzorcom:

=SUM((A1:A4)*((B1:B4)=TRUE);(C1:C4)*((B1:B4)=FALSE))

t.j. zadanie vzorca musí byť ukončené nie stlačením jednoduchého ENTER, ale CTRL+SHIFT+ENTER (CSE), čo sa následne v riadku vzorcov zobrazí ako:

{=SUM((A1:A4)*((B1:B4)=TRUE);(C1:C4)*((B1:B4)=FALSE))}

Zpět do poradny Odpovědět na původní otázku Nahoru